Função SE no Excel: Como usar na prática?

Quer aprender a usar a função SE no Excel de maneira prática? Então você está no lugar certo!

Dentre as diversas funções existentes no Excel, a função SE pode ser considerada uma das mais importantes e mais utilizadas. Você pode usar a função SE para testar uma condição e retornar um valor se a condição for atendida ou outro valor se a condição não for atendida.

Neste tutorial, mostraremos a sintaxe e os usos mais comuns da função SE no Excel e, em seguida, vamos mostrar alguns exemplos que, esperamos, serem úteis tanto para iniciantes quanto para usuários experientes do Excel. Confira!

Já está interessado(a) no que vem por aí? Então compartilhe com sua rede de amigos para que mais pessoas possam aprender a usar a função SE no Excel:

Facebook

Twitter

Google+

LinkedIn

Quando usar a função SE no Excel?

A função SE no Excel é indicada para situações onde se precisa verificar se uma condição é VERDADEIRA ou FALSA. Se for VERDADEIRA, a função retorna um valor ou referência especificada e se for FALSA, retorna outro valor ou referência especificada.

Sintaxe: = SE(teste_lógico, [valor_se_verdadeiro], [valor_se_falso])

Onde:

  • teste_lógico:  é a condição que você deseja testar. Pode ser uma expressão lógica que pode ser avaliada como VERDADEIRO ou FALSO. Isso pode ser uma referência de célula, resultado de alguma outra fórmula, ou pode ser inserido manualmente.
  • [valor_se_verdadeiro]: (Campo Opcional). Esse é o valor retornado quando o teste_lógico é avaliado como VERDADEIRO.
  • [valor_se_falso]: ( Campo Opcional). Esse é o valor retornado quando o teste_lógico é avaliado como FALSO.

Função SE no Excel – Exemplos práticos

Abaixo estão alguns exemplos práticos para que você possa aprender a usar a função SE no Excel em diferentes cenários.

Exemplo 1: Verificando uma condição numérica

Quando se usa a função SE com números é possível usar vários operadores para verificar uma condição. Abaixo est[a a lista de operadores que você pode usar:

Operadores numéricos no Excel

Abaixo temos um exemplo onde as notas dos alunos de uma sala são analisadas. Se as notas forem maiores ou iguais a 5, a função retornará Aprovado, senão retornará Reprovado.

=SE(A2>=5;"Aprovado";"Reprovado")

Função SE no Excel

Exemplo 2: Função SE aninhada

É possível usar a função SE aninhada com até 64 condições simultâneas, no entanto, nós não aconselhamos que você use funções SE muito longas. Mas caso você tenha condições limitadas, é possível usar a função SE de maneira muito prática.

Note no exemplo abaixo que estamos verificando duas condições:

  • A primeira condição verifica se as notas dos alunos são menores que 5. Se isso for VERDADEIRO, ele retornará “Reprovado“.
  • Caso a primeira condição seja FALSA, então significa que o aluno pontuou acima ou igual a 5. Deste modo, a função irá verificar se há outra condição. Então verifica se as notas são maiores ou iguais a 7,5. Se isso for verdade, ele retorna “Excelente“, senão simplesmente retornará “Aprovado“.
=SE(A2<5;"Reprovado";SE(A2>=7,5;"Excelente";"Aprovado"))

Função SE aninhada

Exemplo 3: Calculando comissões com a função SE

A função SE no Excel também pode ser muito útil para realizar cálculos conforme um critério. Um ótimo exemplo é o cálculo de comissão de vendas cujo percentual varia de acordo com a quantidade vendida.

No exemplo abaixo, um vendedor não recebe comissão se as vendas forem inferiores a R$50,00. Por outro lado, ele receberá uma comissão de 2% se as vendas estiverem entre R$50,00 e R$100,00 e 4% de comissão se as vendas forem superiores a R$100,00.

Aqui está a fórmula usada:

=SE(B2<50;0;SE(B2<100;B2*2%;B2*4%))

Exemplo de Função SE aninhada

Como se pode observar, na fórmula usada no exemplo acima, o cálculo já é realizado dentro da própria função SE. Deste modo, quando o valor de venda está entre R$50,00 e R$100,00, o Excel retornará o resultado de B2*2%, que é a comissão de 2% com base no valor de vendas.

Exemplo 4: Função SE com operadores lógicos (E e OU)

Para aumentar ainda mais o poder da função SE, também é possível usar operadores lógicos (E e OU) aninhados para testar várias condições de uma só vez.

No exemplo abaixo, queremos selecionar alunos para a bolsa com base em notas e frequência. Neste caso, um aluno é elegível somente se ele pontua mais de 80 e tem a presença em mais de 80% das aulas.

Função SE aninhada com E e OU

Neste caso, podemos usar a função E dentro da função SE para primeiro verificar se ambas as condições foram atendidas ou não. Se as condições forem atendidas, então a função Qualificado, senão retorna Não Qualificado.

Aqui está a fórmula que fará isso:

=SE(E(B2>80;C2>80%);"Qualificado";"Não Qualificado")

Função SE no Excel com E

Exemplo 5: Função SE para converter erros

A função Se no Excel também pode ser usada para se livrar das células que contêm erros.  Apesar de não a melhor opção para tratar erros no Excel, você pode converter os valores de erro em espaços em branco ou zeros ou qualquer outro valor.

Aqui está a fórmula que vai fazer isso:

=SE(SEERRO(A1);0;A1)

A fórmula acima retornará o valor 0 (zero) quando há um valor de erro, caso contrário, retornará o valor da célula.

Dicas importantes para usar a função SE no Excel

Quando estiver usando a função SE no Excel, esteja atento as seguintes dicas:

  • Você pode utilizar no máximo 64 condições aninhadas a uma função SE.
  • Se algum argumento for uma matriz, cada elemento da matriz será avaliado.
  • Se você omitir o argumento FALSO ( valor_se_falso ), isto é, existir apenas uma vírgula após o   argumento value_se_verdade, a função retornará um 0 quando a condição for FALSA.

Por exemplo, na fórmula é =SE(A1>20;”Aprovado”;) não estamos especificando o valor_se_falso. No entanto, o argumento valor_se_verdadeiro ainda é seguido por uma vírgula. Isso retornaria 0 sempre que a condição verificada não for atendida.

Dica 1 para usar a função SE no Excel

  • Do mesmo modo, se você omitir o argumento VERDADEIRO ( valar_se_verdadeiro) e especificar apenas o argumento valor_se_falso, a função retornará um 0 quando a condição for VERDADEIRO.

Por exemplo, a fórmula é =SE(A1>20;;”Aprovado”), onde o  valor_se_verdadeiro não é especificado (somente um ponto e vírgula é usado para especificar o valor_se_falso ). Isso retornaria 0 sempre que a condição verificada for atendida.

Dica para usar a função SE

Baixe aqui os exemplos citados neste tutorial

Dica de Leitura: 

E então, o que achou da explicação da função SE no Excel? Deixe o seu comentário abaixo, gostaríamos muito de conhecer a sua opinião! Para conferir mais dicas de Excel, continue acompanhando o Excel Easy!