Saiba como utilizar as funções SEERRO e PROCV no Excel

A função PROCV é uma das mais utilizadas no Excel, pois com ela é possível realizar buscas de maneira rápida e eficiente.
No entanto, quando o PROCV realiza as buscas e não encontra os resultados ele trás uma mensagem de erro (#N/A). Esta mensagem além de deixar a planilha “feia”, também pode acabar afetando outros cálculos.
Deste modo, para que isto não ocorra, basta utilizar as funções SEERRO e PROCV aninhadas.

E se você ainda não sabe como utilizar essas duas funções juntas, então confira o passo a passo a seguir!

Já está interessado(a) no que vem por aí? Então compartilhe com sua rede de amigos para que mais pessoas possam aprender a utilizar as funções SEERRO e PROCV no Excel:

Facebook

Twitter

Google+

LinkedIn

Saiba como utilizar as funções SEERRO e PROCV no Excel

A função PROCV já sabemos como ela funciona, (se ainda não conhece acesse este link). Já a função SEERRO tem como objetivo retornar um valor específico sem gerar erro, ou seja, se a fórmula tiver erro ela não irá retorná-lo, caso contrário retornará o resultado da fórmula.

Sintaxe

SEERRO(valor, valor_se_erro)

Onde:

Valor: Item obrigatório, é o argumento verificado quanto ao erro.
Valor_se_erro: Item obrigatório. É o valor a ser retornado se a fórmula gerar um erro. Os erros considerados pela função são: #N/D, #VALOR!, #REF!, #DIV/0!, #NÚM!, #NOME? ou #NULO!.

Exemplo Prático

Para entendermos melhor como o SEERRO e PROCV funcionam juntos, vamos utilizar um exemplo onde em uma planilha temos o nome e as idades de algumas pessoas, como na imagem abaixo:

SEERRO e PROCV no Excel

Vamos supor que temos outra tabela com os nomes e precisamos utilizar a função PROCV para nos trazer a idade destas pessoas.

SEERRO e PROCV no Excel

Note que os nomes que o Excel não encontrou retornam com o erro (#N/D) e para que isto não ocorra, iremos utilizar a função SEERRO. Confira o passo a passo:

Passo 1

O primeiro passo é colocar a função SEERRO antes do PROCV(SEERRO(PROCV, valor_se_erro), assim estaremos dizendo ao Excel que se a função PROCV não encontrar o valor procurando, então ele não me trará o #N/D:

=SEERRO(PROCV(F2;$A$2:$B$21;2;0)

Passo 2

Ao final da função PROCV você deve acrescentar a segunda parte do SEERRO, (valor_se_erro). Então ao final do PROCV utiliza-se o ponto e vírgula (;) e coloca-se as aspas (“”).

Vale destacar que se for digitado apenas (“”), então em caso de erro a função não me retornará nada. No entanto, também é possível digitar entre “”, a informação que deseja-se retornar. Exemplo: “valor não encontrado”.

Para o exemplo valor utilizar apenas “”. Desta forma, estaremos dizendo ao Excel que se o PROCV não encontrar o valor procurado ele não deverá retornar nada.

Com isso, a função ficará da seguinte maneira:

=SEERRO(PROCV(F2;$A$2:$B$21;2;0);””)

Saiba como utilizar as funções SEERRO e PROCV no Excel

Agora é só teclar “Enter” arrastar a fórmula para as demais células e conferir o resultado:

SEERRO e PROCV no Excel

Exemplo 2

Como dissemos anteriormente, na função SEERRO entre as aspas (“”) podemos colocar a informação que desejamos que apareça caso a função retorne erro. Então você poderá colocar a informação que desejar, como no exemplo abaixo:

Saiba como utilizar as funções SEERRO e PROCV no Excel

Agora suas planilhas ficarão livres daqueles erros chatos e você poderá aplicar a função SEERRO e PROCV juntas sempre que precisar!

Gostou da dica? Compartilhe com seus amigos para que mais pessoas possam aprender a usar a função SEERRO aninhada com PROCV!