Resolvendo erros no Excel : Erro #REF!

Dando continuidade a série de artigos sobre erros no Excel, hoje falaremos sobre o erro #REF! bem como a causa de sua ocorrência e a solução deste erro no Excel. Se você ainda não viu os artigos anteriores no qual abordam os erros: #N/D e #VALOR! basta clicar nos links indicados para acessá-los. No mais, acompanhe os detalhes a seguir:

Erros no Excel

O que significa #REF!

O erro #REF! no Excel, ocorre quando uma referência de célula não é válida. Neste caso, o termo referência de célula representa uma única célula ou um intervalo de células.
Exemplo:

B2
C3:F3
Plan2!A1

Neste caso, quando estamos atuando em uma fórmula e esta não consegue identificar a referência de determinada célula, o erro #REF! surge.

Exemplo prático:

Para melhor compreensão a respeito do erro #REF! vamos utilizar um exemplo prático conforme abaixo:

erro #REF

 

Se quiséssemos utilizar a função PROCV para retornar o ID de um usuário, poderíamos utilizar a fórmula fazendo referência a coluna B (identificada como a coluna 2):

Neste caso aplicamos a função da seguinte maneira:

=PROCV(“Alex”;A1:B6;2;0)

Erro #REF - 1

 

Erro #REF - 2

Se por acaso trocássemos essa referência pelo número 3, geraria o #REF!, porque no intervalo A1:B3 existem apenas duas colunas, não três:

 

Erros #REF - 3

 

Erro #REF - 4

 

Outro caso onde pode ocorrer o erro #REF! é quando uma célula é copiada e colada em outro local de referência inválida.

Exemplo:

Na célula B4 tenho a fórmula = SOMA(B1:B3). Então, copiaria a B4 e colaria na C3. Não seria possível criar uma referência válida para a fórmula que teria que ficar =SOMA(C0:C2). Porque aumentou uma coluna e subiu uma linha, mas, não existe linha 0.

Solução:

Provavelmente este seja um dos erros no Excel mais difíceis de solucionar, porque envolve perda de referências, e para descobrir, você precisa conhecer bem a planilha que está trabalhando, do contrário terá que analisar bastante para descobrir a quem se referenciava as fórmulas quebradas. Para corrigir estes erros, precisamos identificar o que pode estar causando a mensagem de erro, e resolver com algumas das seguintes ações:

  • Se você tiver acabado de colar ou excluir células, clique no botão desfazer (CTRL+Z) para recuperar a fórmula original que estava antes de apresentar a falha.
  • Verifique se a planilha possui alguma referência a planilha externa e certifique-se que este objeto esteja perfeito.
  • Verifique se a fórmula com problema foi gerada por macro e que esta gera uma referência que atingiria uma posição menor que a primeira linha ou coluna.

 

Gostou da dica? Confira mais dicas de Excel, Planilhas, VBA e Tutoriais em nosso site!

Fonte: exceldoseujeito.com.br