Resolvendo erros no Excel : Erro #N/D

O artigo de hoje será o primeiro  artigo da série sobre de dicas de correção de erros no Excel no qual serão publicadas ao longo dos dias.

Se você já trabalha com o Excel ou se aventura neste software em certas ocasiões, perceberá que quando se trabalha com funções principalmente, alguns erros surgem e você na maioria das vezes não consegue entende-los e muito menos resolve-los.

Pensando neste assunto, a dica de hoje começa com um primeiro erro muito conhecido: Erro  #N/D. Veja a seguir detalhes sobre este erro no Excel.

Erros no Excel parte 1

 

O que significa #N/D?

O tipo de erro #N/D significa que um valor não está disponível para uma função ou fórmula.

Pode ocorrer quando, por exemplo, for fornecido um valor inadequado em argumentos das funções PROCV, PROCH ou CORRESP. Ou, quando uma fórmula matricial está usando um argumento que não tem o mesmo número de linhas ou colunas que o intervalo que a contém, dentre outros onde identifique-se algo relacionado a dados ausentes.

Observe o seguinte exemplo:

Procv

Se quisermos utilizar a função PROCV para mostrar o preço da fruta, ao digitar o nome dela, basta usar a seguinte fórmula:

=PROCV(D6;A2:B7;2;VERDADEIRO)

Procv 1

 

 

Ao teclar enter, veja que temos o erro #N/D

procv 2

 

Ou seja, o PROCV não encontrou o valor procurado ( que representa a célula D6). Deste modo é impossível fazer uma procura vertical, se o valor procurado está em branco.

Neste caso, basta inserir um valor na lista para ter o resultado esperado. Veja:

Procv 3

 

Alternativa:

 

Outra alternativa para o exemplo citado acima é utilizar a função ÉERROS, veja como:

=SE(ÉERROS(PROCV(D6;A2:B7;2;VERDADEIRO));””;(PROCV(D6;A2:B7;2;VERDADEIRO)))

Ou seja, se a função PROCV trouxer como valor algum erro, apareça “nada”, se não utilize a função PROCV. Ao teclarmos Enter, veja que mesmo com o campo “Fruta” em branco, não teremos o erro na célula que mostrará o preço.

procv 4

 

 

Outras soluções:

Além da função Procv, existem ainda outras soluções para serem aplicadas no caso do erro #N/D aparecer em outras funções. Veja como:

  • Verifique se você inseriu um valor ou uma referência de célula no lugar de uma referência de intervalo. No caso do valor procurado não estar sendo encontrado, talvez seja interessante executar alguns destes procedimentos listados neste artigo.
  • Por padrão, as funções que procuram informações em tabelas devem ser classificadas em ordem crescente. Entretanto, as funções de planilha PROCV e PROCH contêm um argumento pesquisa_de_intervalo que fornece instruções para que a função localize uma correspondência exata, mesmo que a tabela não esteja classificada. Para localizar uma correspondência exata, defina o argumento pesquisa_de_intervalo como FALSO. No caso da função CORRESP este argumento chama-se tipo_correspondência, execute o mesmo procedimento.
  • Se você estiver usando uma fórmula matricial, você tem que verificar se a referência ao intervalo está compatível com a quantidade de linhas ou colunas do seu intervalo. Ou seja, se você está utilizando a fórmula nas células do intervalo A1:A10, você deve referenciar um intervalo de 10 linhas em sua fórmula, pois, se, por exemplo, você definir apenas um intervalo de B1:B5, os resultados de A6 até A10 será #N/D.
  • Sempre insira todos os argumentos necessários na função que retorna o erro e nas posições corretas.
  • Outro caso que pode ocorrer é de uma pasta de trabalho relacionada não estar aberta ou com problemas. Com estas ações, você poderá corrigir possíveis erros na digitação de suas fórmulas. Se o caso, não for passível de correção, ou seja, um erro seja esperado ou previsto no retorno de sua fórmula, mas, você quer tratar este erro para que sua planilha fique mais elegante, sem exibir #N/D nas células.

Não deixe de conferir os demais artigos da série e domine de vez os erros no Excel. Até a próxima!

 

Gostou da dica? Veja maiores informações sobre Excel em nosso site!

Fonte: exceldoseujeito.com.br